Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Elite Pro 70X5FD deaf to MSC-400 RS232
This thread has 5 replies. Displaying all posts.
Post 1 made on Monday October 8, 2012 at 10:33
malibu1
Lurking Member
Joined:
Posts:
October 2012
5
Have serial control from MSC-400 to Elite Pro 70X5FD TV and a Denon AVR.
Denon RS232 control works perfectly but the TV won’t respond to the RS232 commands from the MCS-400.

TV will respond to commands sent from laptop using Hyperterminal.
Connected MSC cable to Hyperterminal and see the correct commands being sent by the MSC-400.
Triple checked the port settings to be 9600, N,8,1.
Have null modem on TV as required by Sharp.
Switched the Denon cable to the TV port and connected it to the TV, no response from TV.
Reprogrammed and switched TV and Denon serial ports on the MSC-400 and still no response from TV.

Any suggestion for what to try next?
Post 2 made on Monday October 8, 2012 at 22:31
Lowhz
Senior Member
Joined:
Posts:
April 2012
1,168
Are you using only the URC RS232 cable to the TV or do you have it coupled to a null modem? Are you using the serial codes in the built-in library or did you write your own strings?
Post 3 made on Monday October 8, 2012 at 22:35
Duct Tape
Loyal Member
Joined:
Posts:
November 2008
5,218
I just did a 60 elite with an msc400.  I believe all i needed was a male urc serial cable. No null modem adapter.
[Link: facebook.com]
OP | Post 4 made on Tuesday October 9, 2012 at 15:01
malibu1
Lurking Member
Joined:
Posts:
October 2012
5
Used a null modem to talk to the TV with Hyperterminal with no problem.

Wrote my own strings from the Sharp manual and they work when sent from Hyperterminal.

I'm sure I tried going direct (no null modem) from the MSC-400 with no success, but I'll try that again.
Post 5 made on Tuesday October 9, 2012 at 15:37
Duct Tape
Loyal Member
Joined:
Posts:
November 2008
5,218
are you entering the carriage return within each code, or do you have the checkbox clicked to automatically enter a carriage return?  if you are doing both, that would be a common problem.
[Link: facebook.com]
OP | Post 6 made on Wednesday October 10, 2012 at 09:00
malibu1
Lurking Member
Joined:
Posts:
October 2012
5
Case closed.
Apparently I didn't try it without a null modem and that did the trick. Thank you Duct Tape et. al.


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse