Your Universal Remote Control Center
Complete Control by URC Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Monday November 13, 2006 at 17:23
Long Time Member
August 2006
Has anyone been successful controlling a Fujitsu plasma via RS-232 from the MSC-400? I am unable to make this work at all and have been banging my head against it for the last 24 hours, will get in touch with URC tomorrow.

Display is a new Fujitsu P50XTA51US.

I have the latest software, firmware, and DB updates for the MSC, and have it successfully controlling 2 other components via serial, so it's not a unit-wide problem.

The connection settings for the plasma are per Fujitsu's spec (4800,n,8,1), but I get no response to any of the commands in the serial DB when testing through the MSC editor... including trying the @G\r to initiate a connection as mentioned in an RTI thread. Have device options set to ASCII and automatic carriage returns, but have also tried all the other combos without a different result.

Using Hyperterminal on my laptop and a standard serial cable, I can open a connection to the plasma and operate it properly using the codes from the MSC serial DB, so it's not a problem with the display itself. I also connected the MSC serial cable back to the laptop and validated through Hyperterminal that it is transmitting the commands when testing through the editor.

I have also tried 2 different MSC serial cables again with no change in results.

I suspect at this point that either the Fujitsu pinouts are different than those of the MSC cables or there is a bug in the MSC software somewhere...

Any thoughts or secrets to share?


Hosting Services by ipHouse