Your Universal Remote Control Center
Philips Pronto Professional Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 4 made on Tuesday June 14, 2022 at 19:29
Long Time Member
July 2004
Sorry about the late response - my browser has cached this thread despite a few restarts and reboots, and I just haven't reloaded this page until now.

It's working right now, I've switched from the broadcast address for my local network ( to It is not clear to me why that would make a difference, especially since the simulator was working either way.

I've tried a few things on the way, among others, I've run netcat on my Raspberry Pi, listening for UDP packets I've sent in unicast and broadcast mode from both the Pronto and the simulator:
$ sudo nc -u -dkl 234
and then sent plain text e.g. with
UDPSocket.send("packet ", "", 234);
That should work for port 9 (where WOL packets are sent) instead of 234 as well.

On May 29, 2022 at 02:21, Lyndel McGee said...
Is there a version 7.4.22? Latest I'm aware of is 7.3.3.

There is, see e.g. here: [Link:]

In order for your Pronto to use TCP and UDP sockets, you must configure the network mode to support Serial Extenders.

I can use TCP sockets, contolling the AVP via TCP after I've turned it on by other means (e.g. from the simulator) works (minus my bugs regarding socket reuse and reading back unsolicited status updates)

Next, you might try wrapping your code with a try/catch block to trying to determine what exception you are getting using System.print(err).

That doesn't provide any additional information: the exception name is "Panel Error" and the exception message is "Socket error". The stack is just the pretty shallow call stack from the button to the sendWOL() function. It's basically the same I've seen in onIOError() callback.

Have you also tried this? Found via a search for Wake On LAN.

see [Link:] post no. 7

sorry, I can't see any actual link there. was it this one? [Link:]

I presume the device you are trying to wake up is hard-wired to your network and not Wifi?


If it is Wifi, then you may have an issue with your router/access point not allowing a wifi device to connect to and send commands to another device on my network.

I now know that that is not the case, since I was able to send WOL packets from a linux laptop connected to the same WiFi network and access point the Pronto uses, and that successfully wakes up the AVP. The access point runs in bridge mode, so broadcast packets should be absolutely no problem.

I still have the weird issue that the simulator cannot use TCP sockets - at least there the error message is a bit more verbose "Failed to connect". I can connect to all the devices from the same Windows PC using e.g. putty. Any Ideas regarding that?

Hosting Services by ipHouse