Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Original thread:
Post 7 made on Friday April 23, 2021 at 15:21
punter16
Active Member
Joined:
Posts:
May 2011
546
On February 3, 2021 at 10:28, shokwaverider said...
I have had a few customers complain lately that when they plug in their 880 or put their 980 on the charging cradle that the batteries do not charge. But if the batteries are charged with an external 3rd party charger the batteries are actually good and work well when put back in the remote.

I have engineered a fix for this. The Charging chip in these remotes goes bad. There is a very inexpensive 3.7v Li-ion charging PCB, that can relatively simply be fitted into the remote and wired to bypass the charging chip (3 small wires).

An added benefit is that the new charger almost halves the charging time and if located correctly shows the user when the battery is charging AND when it is fully charged (Not normally available with the 810 and 880 that do not come with cradles) I have added a window on the back of some of our test remotes so the charging status is clearly visible. Otherwise one has to remove the battery cover while charging to see the internal LED status.

This fix does not bypass the charging indicator on the display, so the remote looks and fees as if nothing has changed.

Has anyone else done this? I have not written a document about it but anyone with good soldering skills can effect the change. It is easy to explain if anyone is interested.

Interesting. We have been seeing issues for about 2 years with MX990s where they won't charge. Has URC acknowledged this at any point?


Hosting Services by ipHouse