Your Universal Remote Control Center
UEI Nevo Remote Controls Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 2 made on Sunday November 17, 2019 at 08:38
Lurking Member
January 2010
Hello everybody!
I have a S70 remote and NSP 3. Everything worked well (at least for about 8 years ago) then it started to reboot and loss battery capacity. I havent used it since then.
Last week I picked it up and gaved it a new try
I looked in this forum for possible resons to my problem and found that it was the button under the plastic cover on the remote that didnīt put the button down proberly. I fixed it with a piece of wood glued to the plastic piece that push on the button. Thanks to this forum!
But the next problem I donīt solve. Iīve read all threads in this forum about connection problems and my problem is that i canīt connect to my computer with USB. This is the same computer that runs the NSP 3 and Iīve used it to connect via USB earlier (8 years ago).
I changed the USB cable- no difference.
I tried to establish a wifi connection, but didnīt get it to work.
Please help me to solve the connection problem!
When I connect the S70 remote to the computer via USB cable, a beep sound appears. Then, when I press download configuration a window pops up that says Please connect Nevo...
Any solutions anybody?
I`m not a professional installer, but back in the days I worked with proffessional installers here in Sweden.
Thank you in advance!

Last edited by Svante on November 17, 2019 09:26.

Hosting Services by ipHouse