Your Universal Remote Control Center
UEI Nevo Remote Controls Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Tuesday October 23, 2012 at 06:25
Lurking Member
October 2012
Hello you all. Love the help I've seen people get so far. Maybe you all can help. I have searched high and low.

I have a Nevo S70. It looks brand new. Has box and everything. Installed NSP. Upgraded to most current version. I am using Windows XP (SP3)

So it didn't have a battery, so I bought one on ebay. It came. I tried to charge the unit but it doesn't. When you place it on the cradle, it loads up the splash screen... then turns off.

When you plug it into the USB port of my computer, the screen turns white and the USB device is not recognized.

When you place it on the cradle and as it turns on, hold down the scroll button, the unit goes into USB mode.

When you then plug the unit into the computer, a new drive letter shows up, however it still doesn't seem like its recognized because the NSP program doesn't really see it.

I did what they recommended on their forums on the nevo site, ([Link:]) by putting the remote into USB download mode by powering off and then powering on the remote while pressing and holding the scroll wheel.The screen should indicate USB download mode at the top of the touch screen.(which it does) Then re-activate the Firmware update Wizard within NevoStudio Pro 3.0 and instead of selecting all firmware types (Eboot, ROM, Nevo App, Z-Wave) select each one independently and restart the Firmware Update Wizard for each firmware type.

Well as I place it in that mode, and run the firmware update, the software will find the unit, but it takes a minute, then has nothing listed under "Current", for all 5 (Eboot, ROM, Nevo Version, Blaster, Z-Wave) then it has checkmarks behind Eboot, ROM, Nevo Version)

When I update them one at a time, it seems to load a new eboot, but then it asks to plug the unit back into USB mode to verify and it never is able to verify it.

Same with the ROM. Seems to install, the remote says its installing, then it hangs.

With the Nevo firmware, it never even starts the process because it cannot see the unit.

When I plug it into and computer, it isn't found.

I do have active sync on this computer, but it doesn't see the remote.


Thank you!

Hosting Services by ipHouse