Your Universal Remote Control Center
RTI Control Systems Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


RTI T2x Wi-Fi Issue
This thread has 1 response. Displaying all posts.
Post 1 made on Wednesday April 21, 2021 at 04:53
Junior Member
April 2021

I have an issue with a T2x remote,I can't seem to connect the remote to my Network. I have tried multiple access point , DHCP and Manually but it still doesn't work.
I don't know if I'm missing something but I can't seem to connect ( I displayed the remote's address on the screen and it's always

Network adapter is enabled.

If you have any awnser thanks.
Post 2 made on Wednesday September 1, 2021 at 19:21
New Member
September 2021
Make sure itís firmware upgraded to the latest file. Make sure your WiFi encryption is set up properly IE if itís WPA2-PSK make sure that reflects on the 802.11 tab in the device properties. Then if that doesnít work try to remove any special characters from the WiFi broadcast name. If all else fails, load a blank file to the device and re load the program.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse