Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto NG Family Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
TSU 7500 broken screen / LCD
This thread has 13 replies. Displaying all posts.
Post 1 made on Monday April 30, 2007 at 18:46
Doug_L
Long Time Member
Joined:
Posts:
November 2002
28
I've got a TSU 7500 which is maybe 1 year-old at most. Yesterday the screen started to malfuntion in the following way:
- the colors have become almost totally faded;
- blacks are not particularly well pronounced (text is difficult to read);
- there are a number of horizontal black lines (about 1/2 dozen) across the entire screen, mostly in the middle (not top or bottom);
- the change in color and contrast characteristics are consistent throughout screen (ie: there are no hot-spots).

It's possible the unit was dropped, though I can't recall any specific event. There does not appear to be any damage to the housing or the glass screen. I have reconfigured screen, re-flashed memory and upgraded to most recent version of firmware. No change, and no solution.

Presuming that this is a problem with the LCD, what are my options? Will Philips repair?(I admit I have not yet tried to contact them) Are replacement LCD's available and what is approximate cost?

I've done a search but haven't found anything definitive on the subject. There was a post or two about replacing (and cracking) the glass but I don't recall seeing anything about LCD.

Thanks in advance.

Last edited by Doug_L on April 30, 2007 21:30.
Post 2 made on Monday April 30, 2007 at 23:35
ANILE8
Long Time Member
Joined:
Posts:
April 2006
11
I too have just had the same problem with another TSU7500 belonging to one of my customers. With exactly the same symptoms as you have described.

What the hell is going on with these units. This is the second TSU7500 I am going to have to send back to Philips with a screen problem!
Post 3 made on Thursday May 3, 2007 at 09:09
ossocao
Active Member
Joined:
Posts:
April 2004
637
On April 30, 2007 at 23:35, ANILE8 said...
I too have just had the same problem with another TSU7500
belonging to one of my customers. With exactly the same
symptoms as you have described.

What the hell is going on with these units. This is the
second TSU7500 I am going to have to send back to Philips
with a screen problem!

It looks like a bad contact problem. I whould start opening the remote and cleaning the contacts of the LCD. You will find a ribon conectiong the screen to the board.

If you are shure you have a bad LCD, search this forum and you can buy a spare screen.
Post 4 made on Friday May 18, 2007 at 18:18
filezz
Lurking Member
Joined:
Posts:
May 2007
8
I never could find in the forms where we could buy the screen for the TSU7500 I only saw it for the TSU7000 Help would be great.
Post 5 made on Saturday May 19, 2007 at 08:35
ossocao
Active Member
Joined:
Posts:
April 2004
637
7000 and 7500 use the same screen.
Post 6 made on Saturday May 19, 2007 at 08:48
ossocao
Active Member
Joined:
Posts:
April 2004
637
The 7500 uses the same screen.

http://www.services.foxconn.com

Look for the ipaq 5400 series screen.
Post 7 made on Friday May 25, 2007 at 16:42
filezz
Lurking Member
Joined:
Posts:
May 2007
8
we will see. I just bought the 5400 sceen. We will see if it is the right one.
Post 8 made on Friday May 25, 2007 at 17:58
ossocao
Active Member
Joined:
Posts:
April 2004
637
Let us know, but Im quite shure it will work. Read the threat about replacing the screen or you can have your new one broken.
Post 9 made on Tuesday May 29, 2007 at 18:13
filezz
Lurking Member
Joined:
Posts:
May 2007
8
You would be correct.. It did work..

Pronto now up and working..

Thx
Post 10 made on Wednesday May 30, 2007 at 15:42
ossocao
Active Member
Joined:
Posts:
April 2004
637
I told you ! Enjoy.
Post 11 made on Friday June 1, 2007 at 04:24
tgrugett
Select Member
Joined:
Posts:
August 2004
1,815
On May 19, 2007 at 08:48, ossocao said...
The 7500 uses the same screen.

http://www.services.foxconn.com

Look for the ipaq 5400 series screen.

Just to make sure....

is this the one....

[Link: hhshopper.com]Home%20>%20iPAQs%20>%20h5400
Post 12 made on Friday June 1, 2007 at 13:10
filezz
Lurking Member
Joined:
Posts:
May 2007
8
yes thats the one.
Post 13 made on Friday June 1, 2007 at 13:28
ossocao
Active Member
Joined:
Posts:
April 2004
637
Warning! Search and read about TSU7000 LCD replacment, or else you will problably have you new screen broken.
Post 14 made on Monday June 18, 2007 at 21:04
siyoushuai
Lurking Member
Joined:
Posts:
June 2007
1
Hey, have you solved your problem?

You can visit the following website for help:
www.hhshopper.com

Or, send e-mail to :GSC-DCC-HP@FOXCONN.COM

This is Bill.
Bill Si
siyoushuai
Bill si


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse