Your Universal Remote Control Center
Original Equipment Remotes Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


Pioneer SC-63 remote stopped working
This thread has no replies.
Post 1 made on Tuesday November 29, 2016 at 18:40
Lurking Member
November 2016
Hey y'all, having some very frustrating issues with the remote for my SC-63. Out of no where, it will not control a single blasted thing on my receiver. I've tried swapping batteries with no luck. The little red light on the remote lights up when I push a button, but nothing happens with my receiver. I've also tried using the universal remote that LG uses on their phones. Receiver doesn't respond to that either. It really sucks now, seeing as how their mobile app has has taken a crap on me and doesn't work at all now, either. I'm scared to do a factory reset to see if that helps because if it doesn't work, I'd lose all speaker calibrations and no way to get them back without a remote. Any and all help would be greatly appreciated.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse