Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
MX-450 Firmware Problems
This thread has 10 replies. Displaying all posts.
Post 1 made on Monday October 8, 2012 at 17:58
edbro
Lurking Member
Joined:
Posts:
February 2008
6
I'm in big trouble!

My MX-450 started acting up a bit so I factory reset it and reapplied a backup of the configuration using the archiver software. Since that time the remote has had garbled text and little black squares on the screen making it mostly unreadable. I wrote it off as something bad in the electronics and purchased another one.

Now, here's my big mistake. As soon as I got the new one I tried to apply the backed up config to it. I chose:
1. User Configuration Only.
Except, after it downloaded config data it then downloaded firmware and IR firmware. When the device reset I had the same garbled screen on the new device. There must be something corrupt in the archived backup. I tried another factory reset but it doesn't clear the garbled text.

What are my options? Is there a source to get fresh firmware I could download? Live update seems to only update the archiver software. Is my 2nd remote trash now also? I've only had it 20 minutes! Please help as this is getting very expensive and I still don't have a working remote.
OP | Post 2 made on Monday October 8, 2012 at 18:05
edbro
Lurking Member
Joined:
Posts:
February 2008
6
Very poor pic of the screen. Best I could do with such a tiny screen. But you can see that as you scroll the menu, the text becomes garbled.

[IMG][/IMG]
Post 3 made on Monday October 8, 2012 at 18:34
Duct Tape
Loyal Member
Joined:
Posts:
November 2008
5,214
this was discussed over at the URC Control Room forum.  here is a post from tech support that might help:

"Hey Guys,
We've been getting a couple of 450 remotes in with missing pixels around the "Main" and "Page" buttons. This issue can be fixed and is usually caused by downloading a file from a previous 450 remote that had an earlier firmware version. The Fix: Download the MX-450 archiver, do a Live Update, when downloading to the remote select option 3(Firmware & Database Update)."
[Link: facebook.com]
OP | Post 4 made on Monday October 8, 2012 at 19:04
edbro
Lurking Member
Joined:
Posts:
February 2008
6
Thank you. Fixed!
Post 5 made on Sunday August 18, 2013 at 18:21
howag
Lurking Member
Joined:
Posts:
August 2013
2
I am having a similar problem, but the fix above did nothing. I've tried resetting the remote from the remote to factory settings. Tried resetting the remote to defaults via download.

Have updated the firmware & database repeatedly. Downloaded the MX-450 archiver repeatedly. Everything I've done does not repair the garbled text throughout the remote. It worked wonderfully until I just tried to do a firmware and database update.

Even tried on a totally different machine running Windows 7 instead of 8, but it did nothing.

At this point, I'd be OK, (though miserable) with doing a complete reprogramming of the whole remote, but I can't even get the factory default reset to display correctly, so would be impossible to re-program the whole remote.

At my wit's end. Concerned that I may have somehow bricked it.
Post 6 made on Monday August 19, 2013 at 12:11
howag
Lurking Member
Joined:
Posts:
August 2013
2
Figured this out. Needed to carefully follow the steps here:
[Link: universalremote.com]

I hadn't done this step first:
The first step is to perform a software update to receive the latest IR codes and firmware. Execute a LIVE UPDATE by clicking the Satellite Dish icon, or by clicking HELP > LIVE UPDATE

Usability is a real problem on that archiver software, but I understand this is not really intended to be used by the general public. Love the remote, just have to remember the little intricacies to make it work.

Tech support call was useless. Just gave me a "firmware update should fix that". Oh well, "we'll replace it for you at at the same price you purchased it at". There was no process to go through the actual steps over the phone to do the upgrade to see where I went wrong. Would have only taken a couple of minutes.

Clearly they don't have the residential consumer market penetration to afford real tech support.

Last edited by howag on August 19, 2013 12:28.
Post 7 made on Sunday June 29, 2014 at 08:16
Ensign
Lurking Member
Joined:
Posts:
June 2014
1
I know this thread is old, but just ran I to this issue as well. The key to having this work is running the Archiver as an administrator. Took me awhile to figure this out. If you don't, the program will say 'update required, restarting software' or something to that effect, and nothing will happen. If you run as administrator, you'll then see a dialog box showing you the update process. Hope this helps someone else!
Post 8 made on Saturday February 21, 2015 at 18:47
tdudley4741
Long Time Member
Joined:
Posts:
April 2005
18
Yes, very helpful, thanks!!
Post 9 made on Monday March 13, 2017 at 11:04
HS23
Lurking Member
Joined:
Posts:
March 2017
1
Thanks Dudley! Worked for me!
Post 10 made on Tuesday April 25, 2017 at 15:09
MCoward
Lurking Member
Joined:
Posts:
April 2017
8
This tip from Ensign has proven very helpful to me today. I thought I had thoroughly bricked mine. Thanks, ever so much.
Post 11 made on Saturday February 6, 2021 at 17:53
duchski
Junior Member
Joined:
Posts:
February 2021
1
I know this a very old thread and post but does anybody has the steps necessary to fix the remote? The provided link doesn't work anymore.

Thank you




On August 19, 2013 at 12:11, howag said...
Figured this out. Needed to carefully follow the steps here:
[Link: universalremote.com]

I hadn't done this step first:
The first step is to perform a software update to receive the latest IR codes and firmware. Execute a LIVE UPDATE by clicking the Satellite Dish icon, or by clicking HELP > LIVE UPDATE

Usability is a real problem on that archiver software, but I understand this is not really intended to be used by the general public. Love the remote, just have to remember the little intricacies to make it work.

Tech support call was useless. Just gave me a "firmware update should fix that". Oh well, "we'll replace it for you at at the same price you purchased it at". There was no process to go through the actual steps over the phone to do the upgrade to see where I went wrong. Would have only taken a couple of minutes.

Clearly they don't have the residential consumer market penetration to afford real tech support.
MX-450


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse