Your Universal Remote Control Center
Complete Control by URC Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Monday October 8, 2012 at 17:58
Lurking Member
February 2008
I'm in big trouble!

My MX-450 started acting up a bit so I factory reset it and reapplied a backup of the configuration using the archiver software. Since that time the remote has had garbled text and little black squares on the screen making it mostly unreadable. I wrote it off as something bad in the electronics and purchased another one.

Now, here's my big mistake. As soon as I got the new one I tried to apply the backed up config to it. I chose:
1. User Configuration Only.
Except, after it downloaded config data it then downloaded firmware and IR firmware. When the device reset I had the same garbled screen on the new device. There must be something corrupt in the archived backup. I tried another factory reset but it doesn't clear the garbled text.

What are my options? Is there a source to get fresh firmware I could download? Live update seems to only update the archiver software. Is my 2nd remote trash now also? I've only had it 20 minutes! Please help as this is getting very expensive and I still don't have a working remote.

Hosting Services by ipHouse